Octopus Deploy Documentation

Tentacle Installation Requirements

Last updated

If you're using a version prior to Tentacle 3.1, refer to the installation requirements for older versions of Tentacle.

The installation requirements for the latest version of Tentacle are:

Windows Server

  • Windows Server 2008 R2
  • Windows Server 2012
  • Windows Server 2012 R2 
  • Windows Server 2016 (Both "Server Core" and "Server with a GUI" installations are supported for Tentacle).
  • Windows Server 2019

.NET Framework.

  • Tentacle 3.1+ (TLS 1.0 or 1.2): .NET Framework 4.5.2+ (download).

Windows PowerShell

  • Windows PowerShell 2.0. This is automatically installed on 2008 R2.
  • Windows PowerShell 3.0 or 4.0 is recommended, both of which are compatible with PowerShell 2.0, but execute against .NET 4.0+.
  • Windows PowerShell 5.1 is required to run Azure steps

Hardware Requirements

  • Hardware minimum: 512MB RAM, 1GHz CPU, 2GB free disk space.

Tentacle uses a small amount of memory when idle, usually around 10MB (it may appear higher in task manager because memory is shared with other .NET processes that are running). When deploying, depending on what happens during the deployment, this may expand to 60-100MB, and will then go back down after the deployment is complete. Tentacle will happily run on single-core machines, and only uses about 100MB of disk space, though, of course, you'll need more than that to deploy your applications.

Download the Tentacle Installer

Long-term Support Octopus Server (Slow lane)

The version of Tentacle that works with the latest long-term support version of Octopus Deploy:

If you need an older version of Tentacle that works with a previous long-term support release, visit the previous downloads page, locate the specific version of Octopus you're working with, and click your version to visit the downloads page for that version.

Fast Lane Tentacle

The version of Tentacle that works with the latest fast lane version of Octopus Deploy:

Python

Octopus can run Python scripts on Windows targets provided the following criteria are met:

  • Python version 3.4+ is installed
  • Python is on the path for the user that Tentacle is running as
  • pip is installed or the pycryptodome python package is installed

Welcome! We use cookies and data about how you use our website allow us to improve the website and your experience, and resolve technical errors. Our website uses cookies and shares some of your data with third party analytics companies for these purposes. We do not use these cookies for advertising.

If you decline, we will respect your privacy. A single cookie will be used in your browser to remember your preference.