Compare releases

Compare releases and check for compatibility between your existing Octopus Server and new releases.

Loading

Unable to load comparison data

We're sorry, we're unable to load that release comparison at this time. Please try again in a few moments.

What's new

These are the most important features you'll get by upgrading from 2025.2.12907 to 2025.3.2738

Octopus 2025.3 2 breaking changes

The new features in Octopus 2025.3 offer clearer insights, faster testing, and better performance.

This release’s noteworthy updates include:

  • Monitor and troubleshoot Kubernetes apps in one place with Live Object Status
  • Faster, safer, and more cost-effective testing with Ephemeral Environments - Early Access Preview
  • Improve performance with more control over package retention policies
  • Greater control over complex processes with a modernized Process Editor

The 2025 Q3 release is already available on Octopus Cloud and is now ready for download by our self-hosted customers.

Breaking changes
  • 9452 - The default C# scripting engine has been updated to dotnet-script, replacing ScriptCS. This is a breaking change. To temporarily revert, set the Octopus.Action.Script.CSharp.UseDotnetScript variable to false. Support for ScriptCS will be removed in 2025.3. For more details see our deprecation schedule and migration guide
  • 9447 - Breaking change: Update the way the tags and excludedTags query parameters are set on the tenants overview page. If you are using a saved link with multiple tags in the same tag set filter, you'll need to re-apply these filters and re-save the link as the URL format has changed

Release notes

These are the features and fixes you'll get by upgrading from 2025.2.12907 to 2025.3.2738.

Changes in Octopus Server 2025.3.2738

  • 9473 - Deployment throws an EntityNotFoundException when accessing deployment target created during deployment

Changes in Octopus Server 2025.3.2613

  • 9557 - Project Deployment Freeze Option not showing on 2025.2.12902 (maybe earlier versions of 2025.2 aswell).
  • 9467 - Updates page areas in global search to match current navigation structure
  • 9470 - Retry worker leasing when all healthy workers are leased exclusively
  • 9458 - Fixed a bug in which, under certain conditions, changes to environments linked to a tenant for a project would not persist
  • 9457 - Azure Account variable scoping to specific process not respected by runbooks
  • 9466 - Add support for evaluating the value of Octopus.Action.TargetRoles on a step if the value uses the Octopus binding syntax

Changes in Octopus Server 2025.3.2120

  • 9459 - Fix upgrade failures with domain SMTP accounts
  • 9110 - Fix an issue where updating the retention policies cron expression did not reschedule the related retention policies job

Changes in Octopus Server 2025.3.1670

Breaking Changes
  • 9452 - The default C# scripting engine has been updated to dotnet-script, replacing ScriptCS. This is a breaking change. To temporarily revert, set the Octopus.Action.Script.CSharp.UseDotnetScript variable to false. Support for ScriptCS will be removed in 2025.3. For more details see our deprecation schedule and migration guide
  • 9447 - Breaking change: Update the way the tags and excludedTags query parameters are set on the tenants overview page. If you are using a saved link with multiple tags in the same tag set filter, you'll need to re-apply these filters and re-save the link as the URL format has changed
Other Changes
  • 9454 - Update onboarding message on space-level insights page when you don't have an enterprise license
  • 9453 - Allow package acquisition on the execution target for Helm and K8s YAML steps
  • 9348 - Jira Base Url setting will error if a trailing slash / is present
  • 6206 - Jira Base Url Configuration Forward-Slash
  • 9445 - Added UI callout for service account OIDC subject if only wildcards are used
  • 9285 - Fix a bug where making multiple changes on the create deployment page could result in stale results showing for the deployments preview
  • 9406 - Fix bug allowing steps to be created with blank worker pools
  • 9440 - Revert change that introduced bug that prevents editing a step that uses a worker pool variable
  • 9444 - A new certificate created for a tenant variable will be initialized to that tenant to reduce chance of misconfiguration
  • 9443 - Jira work item numbers will now be parsed from commit messages and branch names
  • 9429 - Fix release package notes continuing to display a loading state after loading has failed

Changes in Octopus Server 2025.3.839

  • 9122 - Updated error message to include possible solutions to resolve the issue
  • 9441 - Fix unable to select input components in the new project creation dialog triggered from the global search bar
  • 8830 - Added new service message ##octopus[stderr-output] to print stderr logs as info logs
  • 9442 - Initial connection to an SSH endpoint will retry for transient errors
  • 9440 - Revert change that introduced bug that prevents editing a step that uses a worker pool variable
  • 9421 - Configurable package cache retention for workers and targets
  • 9439 - Improve start time clarity for scheduled tasks
  • 9437 - FSharp (F#) scripts are no longer supported and will result in failed deployments. Deployment processes containing F# scripts can still be loaded and modified, but F# script execution will result in deployment failures
  • 9436 - Replace references to Octo.exe and Octopack.js with Octopus CLI
  • 9427 - Add storage level check to default bash health checks
  • 9415 - Improve performance of Azure Run a Script powershell scripts
  • 9433 - Artifactory Generic Feeds using OIDC and incorrectly displaying as the selected authentication method when selecting a Token
  • 9435 - Adding ability to Manage API Keys in Configuration
  • 9432 - Deselecting project when creating deployment freeze removes project from dialog altogether
  • 9431 - Kubernetes Worker can't run as non-root user
  • 9434 - Reduced database storage for variable sets by not serialising default property values
  • 9383 - Improve helm feed error messages
  • 9430 - Automatically re-hash CA certificates in the OctopusDeploy Linux docker image
  • 9426 - Removing deployment target during deployment with large variable sets can have performance problems
  • 9406 - Fix bug allowing steps to be created with blank worker pools