Compare releases

Compare releases and check for compatibility between your existing Octopus Server and new releases.

→
Loading

Unable to load comparison data

We're sorry, we're unable to load that release comparison at this time. Please try again in a few moments.

What's new

These are the most important features you'll get by upgrading from 1.6.3.1723 to 2.0.9.1020

Octopus 2.0

#

Release notes

These are the features and fixes you'll get by upgrading from 1.6.3.1723 to 2.0.9.1020.

Changes in Octopus Server 2.0.9.1020

Since RC6: - 484 - Fixed display of Add Environment button - 462 - Handle authentication of users not in the current computer's domain - 456 - Convert usernames to UPNs when migrating from 1.6 Looking for RC8/2.0.10? - an authentication bug in 2.0.10 makes the build unsuitable for use at this time; a patched replacement is currently in testing.

Changes in Octopus Server 2.0.9.1015

Since RC5: - 476 - Preserve the current environment selection in Firefox during background refresh - 471 - Fixed crash in Tentacle.exe when empty log output is written - 470 - Pre-validate usernames for uniqueness when migrating from 1.6 - 469 - Fix bug preventing machine discovery if the endpoint mapped to multiple existing machines - 461 - Migrate the Environments property from 1.6 for email steps - 459 - Show the task log properly when team permissions are environment-restricted - 452 - Prevent on-dashboard releases being removed by rentention policies when migrated from 1.6 - 449 - Prevent sensitive variables leaking into logs via the "Windows Service" feature - 439 - Show more variables in the binding helper dropdown, and exclude deprecated/legacy items - 438 - Fixed issue preventing SSL bindings being created for the Octopus Web UI - 436 - Fixed bug preventing environments being selected when registering polling Tentacles - 435 - Apply authentication settings from the "IIS web site" feature to applicationHost.config rather than web.config - 434 - Fixed Tentacle.exe register-with crash with NullReferenceException - 432 - Preserve the associated NuGet package versions when releases are migrated from 1.6 - 429 - Provide a timeout for FTP step file transfers - 428 - Fixed race condition potentially causing wrong server thumbprint to be displayed - 426 - Provide Octopus.Action.Package.SkipIfAlreadyInstalled to regain old non-forced deployment behaviour where required - 422 - Problems detecting the latest version of a package on some NuGet servers (esp. TC8) - 401 - Support Host header bindings for the Octopus Web UI - 317 - TRACE/DEBUG logging is off by default Important notes: two issues have been reported relating to Active Directory authentication in this version. Active Directory accounts migrated from a 1.6 installation are not usable and need to be re-created. Authentication across multiple Active Directory domains is also unsupported in this version.

Changes in Octopus Server 2.0.8.977

Since RC4: - 427 - IIS web site feature SSL cert thumbprint now required to prevent failure at deployment - 425 - Slashes in command-line args now properly escaped, fixing installation failures - 423 - Step names now properly validated before migration from 1.6 - 416 - Fixed check for default project group causing failure to start up after restoring a backup - 415 - Fixed several issues preventing AD authentication being set up or used - 414 - Allow a specific set of machines to be targeted when deploying a release via the API or Octo.exe - 397 - Don't show the Invite button for users when AD authentication is in use - 384 - Better names/descriptions for IIS deployment features, to avoid confusion - 365 - Repair RavenDB Storage... option in Octopus Manager Important, scripted Tentacle installation has changed in this version, the new-certificate command is now required.

Changes in Octopus Server 2.0.7.966

Fixes and improvements since RC3: - 408 - Ignore missing scope entities when migrating variables from Octopus 1.6 - 410 - Fix certificate generation regression - 403 - Migrate Retention Policies from Octopus 1.6 - 412 - Succeed when downloading a package on Tentacles if none require it - 413 - Fix migration of FTP steps from Octopus 1.6 - 400 - Fix Tentacle startup on 32-bit architectures - 419 - Generate and save Tentacle certificate at installation to avoid endless regeneration - 424 - Save Project Group Description field - 411 - Show Project Disable checkbox - 394 - Handle hostnames starting with api - 405 - Allow backup intervals >= 24h - 407 - UI fixes for rolling batch size - 416 (partial) - Recreate indexes on Restore of backup to avoid race condition at startup

Changes in Octopus Server 2.0.6.950

Octopus Deploy 2 Release Candidate 3.

Changes in Octopus Server 2.0.5.933

Octopus Deploy 2.0 has been 6 months in the making, and a lot has changed since Octopus 1.6. Octopus 2.0 is a side-by-side upgrade; please view the upgrade guide for details.