Compare releases

Compare releases and check for compatibility between your existing Octopus Server and new releases.

→
Loading

Unable to load comparison data

We're sorry, we're unable to load that release comparison at this time. Please try again in a few moments.

Release notes

These are the features and fixes you'll get by upgrading from 2.6.5 to 3.0.7.

Changes in Octopus Server 3.0.7

  • 1790 - Updated the TeamCity plugin to support --deploymenttimeout parameter for Octo.exe
  • 1799 - Automatic release creation will now continue enumerating projects instead of breaking on the first failure
  • 1786 - Cloud Service Deployment Target dropdown values now load and bind correctly
  • 1789 - Correct license message will be displayed when Octopus Server can be updated
  • 1739 - ActivityLog files are now deleted when deleting documents that have Activity Logs, like ServerTasks
  • 1782 - Deployments no longer fail if a manual step happens after package acquisition
  • 1791 - Added a warning to the Azure target pages about the changes we are planning for 3.1
  • 1780 - Enabled DtdProcessing on XML reader to fix DTD security exception due to default value change in .Net 4.0
  • 1806 - Better error reporting for Migration
  • 1758 - Fixed a NullReferenceException in TaskLogFileWriter that occurred during the Import process
  • 1779 - Now migrating SMTP Settings from 2.6 to 3.0
  • 1781 - Now imports deprecated FTP and Azure steps but prevents subsequent deployment
  • 1764 - Package retention policies for the Built-in NuGet feed will now be respected properly
  • 1772 - Re-enabled pagination for library packages and feeds
  • 1785 - Now supports Windows Services with apostrophe/single-quote in the name
  • 1788 - Step Template drop down now correctly highlights the selected option in edit mode
  • 1750 - Sensitive values are now masked consistently across all types of logs
  • 1796 - Azure SubscriptionId is now validated before allowing you to save
  • 1787 - Arguments for sc.exe are now quoted and escaped more consistently when configuring Windows Services

Changes in Octopus Server 3.0.6

  • 1509 - Now prevents you from adding ActiveDirectory groups to the "Everyone" team
  • 1718 - The Plugins Module has been revived
  • 1770 - Cascading deletes now work as expected (for example, deleting users now also deletes them from teams)
  • 1777 - Health check now uses Environment property rather than WMI to get machine host name
  • 1778 - License is now migrated from 2.6 to 3.0
  • 1771 - Octopus Server will no longer crash when checking for cancelled tasks if the database becomes unavailable
  • 1769 - Hydra now uses the latest Octopus Installers which ensure Tentacles are reconfigured after update

Changes in Octopus Server 3.0.5

  • 1756 - Active Directory authentication now works even if the User does not provide a UPN
  • 1724 - Removed some inaccurate API hyperlinks that are no longer relevant
  • 1755 - Calamari no longer picks the wrong files when running Octodiff which would cause Octodiff to fail
  • 1742 - The Dashboard now updates correctly in more circumstances
  • 1740 - The Dashboard now updates correctly when deployments finish
  • 1652 - The login form now prevents multiple submissions which would have prevented new Active Directory users from signing in
  • 1762 - Extraneous artifacts in backup file no longer crash the data migrator
  • 1763 - Fixed several issues with the IIS Bindings UI
  • 1701 - Deployments with Manual steps and Retention Policies no longer experience a NullReferenceException
  • 1736 - Reverted step parallelism to 2.x behaviour which can be overridden by OctopusBypassDeploymentMutex
  • 1710 - Single quote in environment name no longer breaks pre/post deploy Powershell scripts
  • 1759 - More descriptive exceptions are now thrown for missing files and directories during data import
  • 1751 - Removed misleading validation on Description fields that have no maximum length constraints
  • 1745 - Upload the full package if delta patch fails instead of failing the deployment
  • 1725 - Project variables with whitespace in the name will now work

Changes in Octopus Server 3.0.4

  • 1609 - The SMTP Client is now disposed correctly
  • 1743 - Deleting an Octopus Server instance no longer requires the SQL Database to exist
  • 1717 - No longer downloading packages for skipped steps
  • 1451 - Clarified Authentication Mode in the IIS Web Site deployment feature
  • 1735 - Offline deployments no longer fail when running steps in parallel
  • 1690 - Improved timeliness of getting logs from Calamari
  • 1731 - Improved logging of unhandled exceptions in Calamari
  • 1745 - When Octodiff.exe apply-delta throws an exception the full package is now uploaded as a fall back

Changes in Octopus Server 3.0.3

  • 1730 - Fixed space CSS for Task Summary/Task log and results
  • 1729 - Improved speed of Migrator
  • 1733 - Increase Server Task.Description length to MAX
  • 1726 - SQL Connection kept alive during task log import

Changes in Octopus Server 3.0.2

  • 1723 - Addressed some UI and behavioural bugs on the Step Templates pages
  • 1721 - Fix for z-index for variables pop-up window for bindings
  • 1722 - Increase timeout for database creation during install
  • 1727 - Fix in Tentacle MSI to correct for Service path on previously upgraded Tentacles
  • 1728 - Script console fullscreen now more robust

Changes in Octopus Server 3.0.1

  • 1532 - --deploymenttimeout used in octo.exe and TeamCity plugin now counts hours too
  • 1526 - Changes to cookie behaviour for reasons (see issue for full explanation of result)
  • 1400 - Logging added of how many files were copied to Custom Install Directory
  • 1555 - Semicolon added as email separator in email steps
  • 911 - Artifacts are now collected when a Tentacle job fails
  • 1193 - Variable filtering now works in the UI
  • 1177 - Added Octopus.Web.BaseUrl a default web base URL variable for Octopus
  • 1496 - Added Octopus.Release.PreviousForEnvironment.Id and `Octopus.Release.PreviousForEnvironment.Number'
  • 1533 - Fixed Https bindings when not on the default port
  • 1225 - Added correctly spelled variable IgnoreConfigTranformationErrors
  • 1170 - Octopus.Tentacle.CurrentDeployment.TargetedRoles now always available
  • 1419 - Provide an option for any machine variables (see issue for use and syntax)
  • 1531 - Removed script console timeout
  • 1398 - We now send less log messages when processing XML transforms
  • 1238 - Additional logging added for additional transforms if not found
  • 820 - Environment variables now updated before invoking scripts
  • 1522 - Download icon now links to the correct package in the library

Changes in Octopus Server 3.0.0

  • 1532 - --deploymenttimeout used in octo.exe and TeamCity plugin now counts hours too
  • 1526 - Changes to cookie behaviour for reasons (see issue for full explanation of result)
  • 1400 - Logging added of how many files were copied to Custom Install Directory
  • 1555 - Semicolon added as email separator in email steps
  • 911 - Artifacts are now collected when a Tentacle job fails
  • 1193 - Variable filtering now works in the UI
  • 1177 - Added Octopus.Web.BaseUrl a default web base URL variable for Octopus
  • 1496 - Added Octopus.Release.PreviousForEnvironment.Id and `Octopus.Release.PreviousForEnvironment.Number'
  • 1533 - Fixed Https bindings when not on the default port
  • 1225 - Added correctly spelled variable IgnoreConfigTranformationErrors
  • 1170 - Octopus.Tentacle.CurrentDeployment.TargetedRoles now always available
  • 1419 - Provide an option for any machine variables (see issue for use and syntax)
  • 1531 - Removed script console timeout
  • 1398 - We now send less log messages when processing XML transforms
  • 1238 - Additional logging added for additional transforms if not found
  • 820 - Environment variables now updated before invoking scripts
  • 1522 - Download icon now links to the correct package in the library