Compare releases

Compare releases and check for compatibility between your existing Octopus Server and new releases.

→
Loading

Unable to load comparison data

We're sorry, we're unable to load that release comparison at this time. Please try again in a few moments.

Release notes

These are the features and fixes you'll get by upgrading from 2018.5.7 to 2018.6.15.

Changes in Octopus Server 2018.6.15

  • 4436 - UI improvements to removable list components (for consistency and easy-of-use)
  • 4546 - Cloudformation and Terraform inline script permission required changed to ProcessEdit
  • 4647 - Fixed an issue where legacy variable Octopus.Action.Azure.UseBundledAzurePowerShellModule wasn't being honoured
  • 4669 - Add an option to exclude a machine from the rest of the deployment when using guided failure
  • 4700 - UI improvements to update variable snapshot to make this feature more accessible
  • 4705 - Fixed issue where randomly getting "Cannot read property 'projectIndex' of undefined" error
  • 4706 - Fixed issue where urls referenced in task logs were converted to lowercase during render

Changes in Octopus Server 2018.6.14

  • 4696 - Fatal error messages are now displayed on the task summary
  • 4702 - Fixed the "Load more" paging button, broken in 2018.6.12

Changes in Octopus Server 2018.6.13

  • 4304 - Tasks running on a node that no longer exists are now marked as failed
  • 4466 - Variables to be passed to a Deploy a Release step are only evaluated after being deserialized from JSON
  • 4500 - Output variables are now collected when resuming a child project from an interruption that is deployed using a Deploy a Release step
  • 4553 - Scheduled Trigger for project with Deploy a Release step no longer fails deployment with error The resource 'users-system' was not found.
  • 4646 - Multiple simultaneous interruptions no longer block a deployment from proceeding
  • 4690 - Send email step and test email can now be cancelled
  • 4699 - Server Task Cap and Maintenance Mode state are now included in the output of the show-configuration command
  • 4701 - The UI now caches the available roles, making editing projects quicker when there are a large number of deployment targets

Changes in Octopus Server 2018.6.12

  • 4655 - Automatic machine removal no longer logs a warning if a machine doesn't have a machine policy
  • 4657 - Project overview advanced filters now include filter by environment
  • 4666 - Release version filters out spaces now
  • 4678 - Selected packages in a release is now properly populated when migrating a 2.6 instance
  • 4689 - Deployment creation is now faster when there are many previous deployments for that release
  • 4692 - Infrastructure|Environments now uses paging to improve rendering performance on large lists

Changes in Octopus Server 2018.6.11

  • 4538 - Octopus Server node deletion is now vetoed when tasks are still running on the node
  • 4588 - The command Octopus.Server.exe node can now be used to configure Octopus Server nodes
  • 4589 - Creation and deletion of Octopus Server nodes are now audited
  • 4680 - Email step and subscriptions correctly account for team membership via external security groups
  • 4686 - Deployment error variables are now cleared when a new auto-deployment is queued up
  • 4693 - Reinstate variable substitution in TF template files from packages

Changes in Octopus Server 2018.6.10

  • 4684 - this.replaceLoop is not a function javascript error is now fixed
  • 4683 - Restore ability to substitute additional files when running an inline script
  • 4643 - Fixed issue with trailing spaces on step template names during migrator export

Changes in Octopus Server 2018.6.9

  • 4682 - Reduce polling frequency of project and main dashboards when page is hidden

Changes in Octopus Server 2018.6.8

  • 2672 - Lifecycle auto-deploy-environment now work with tenants
  • 4533 - Octopus high availability clusters are no longer susceptible to military coup when tasks running on the leader node take too long
  • 4677 - "Script0001 - Release to VariableSet RelatedDocument.sql" can now handle migration of large numbers of library variable sets in releases

Changes in Octopus Server 2018.6.7

  • 4652 - Output variables created by deployment steps, such as package installation directory, are now passed through to subsequent steps for offline drop targets
  • 4654 - Fixed a bug with channel scoping when evaluating certificate variables
  • 4658 - The dashboard overview is now much quicker if lots of tags are in use
  • 4663 - Fixed an exception loading feeds in Azure steps when lacking the AccountView permission
  • 4670 - Variable evaluation speed has been improved, making (among lots of other things) built-in repository retention much quicker when there are many variables
  • 4674 - Fixed the permissions checks when creating an account ( CVE-2018-12884 )

Changes in Octopus Server 2018.6.6

  • 4632 - Special characters in package names are now escaped for offline drops
  • 4656 - Bugfix - Avoid double variable replacement of scripts. Introduced in 2018.5.5
  • 4662 - Dashboard groups are now appropriately resized when filters are applied

Changes in Octopus Server 2018.6.5

  • 4659 - Fixed error when updating releases on sql servers with case-sensitive collations

Changes in Octopus Server 2018.6.4

  • 4547 - Project Switcher filter no longer selects the wrong item
  • 4636 - Fix for HashTable parameter error in Service Fabric Deploy Step
  • 4642 - Fixed an error in the accounts overview in Internet Explorer
  • 4651 - Dashboard groups that don't require a scrollbar no longer scroll a few pixel with the mouse wheel
  • 4653 - Improved the speed of Release deletion
  • 4638 - The variable substitution syntax now supports encoding a variable as Base64

Changes in Octopus Server 2018.6.3

  • 4641 - Set Package Transfer file name with standard name format
  • 4648 - Now correctly excluding disabled deployment targets from licensing limits

Changes in Octopus Server 2018.6.2

  • 4383 - Specific and Excluded targets are retained when a deployment fails and it is then re-tried
  • 4415 - Improvements for when choosing a tag with a large number of tenants on the create deployment screen
  • 4590 - Trials started after 30 March 2018 will not fall back to the free Community Edition https://octopus.com/blog/removing-free-tier
  • 4606 - Fix for unknown environment/certificate issue on Service Fabric targets
  • 4627 - Fixing some daily UX frustrations
  • 4631 - The markdown renderer now ignores _ in the middle of words for formatting purposes
  • 4639 - Fixes an issue preventing auto machine cleaning from adding events for machine deletion

Changes in Octopus Server 2018.6.1

  • 4518 - Improved the rendering performance of the dashboard and project overview when there are a large number of cells to display
  • 4608 - ApiKeys API paging links corrected to stop error in Octopus.Clients and load all keys in the UI when a user has > 30 keys
  • 4610 - Server now checks whether there is enough free space before writing the configuration file
  • 4624 - Fixed a bug that prevented Team Add/Edit page from loading
  • 4626 - The “running tasks” link on the Configuration->Nodes page now filters for running tasks for that node, rather than all tasks on that node
  • 4629 - Added step number to the step edit page

Changes in Octopus Server 2018.6.0

  • 4496 - Added RegisterApplicationTypeTimeoutSec to Service Fabric deploy step
  • 4531 - Support for checkbox and drop-down control-types for prompted variables
  • 4571 - Allow migrations by the API between Octopus instances
  • 4605 - External workers have been converted to workers in the default pool and the command line options have been removed, see our documentation on how to manage them
  • 4617 - Fix a bug where confirm dialog is missing when deleting a parent step from the deployment process