Compare releases

Compare releases and check for compatibility between your existing Octopus Server and new releases.

→
Loading

Unable to load comparison data

We're sorry, we're unable to load that release comparison at this time. Please try again in a few moments.

Release notes

These are the features and fixes you'll get by upgrading from 2018.5.7 to 2018.6.9.

Changes in Octopus Server 2018.6.9

  • 4682 - Reduce polling frequency of project and main dashboards when page is hidden

Changes in Octopus Server 2018.6.8

  • 2672 - Lifecycle auto-deploy-environment now work with tenants
  • 4533 - Octopus high availability clusters are no longer susceptible to military coup when tasks running on the leader node take too long
  • 4677 - "Script0001 - Release to VariableSet RelatedDocument.sql" can now handle migration of large numbers of library variable sets in releases

Changes in Octopus Server 2018.6.7

  • 4652 - Output variables created by deployment steps, such as package installation directory, are now passed through to subsequent steps for offline drop targets
  • 4654 - Fixed a bug with channel scoping when evaluating certificate variables
  • 4658 - The dashboard overview is now much quicker if lots of tags are in use
  • 4663 - Fixed an exception loading feeds in Azure steps when lacking the AccountView permission
  • 4670 - Variable evaluation speed has been improved, making (among lots of other things) built-in repository retention much quicker when there are many variables
  • 4674 - Fixed the permissions checks when creating an account ( CVE-2018-12884 )

Changes in Octopus Server 2018.6.6

  • 4632 - Special characters in package names are now escaped for offline drops
  • 4656 - Bugfix - Avoid double variable replacement of scripts. Introduced in 2018.5.5
  • 4662 - Dashboard groups are now appropriately resized when filters are applied

Changes in Octopus Server 2018.6.5

  • 4659 - Fixed error when updating releases on sql servers with case-sensitive collations

Changes in Octopus Server 2018.6.4

  • 4547 - Project Switcher filter no longer selects the wrong item
  • 4636 - Fix for HashTable parameter error in Service Fabric Deploy Step
  • 4642 - Fixed an error in the accounts overview in Internet Explorer
  • 4651 - Dashboard groups that don't require a scrollbar no longer scroll a few pixel with the mouse wheel
  • 4653 - Improved the speed of Release deletion
  • 4638 - The variable substitution syntax now supports encoding a variable as Base64

Changes in Octopus Server 2018.6.3

  • 4641 - Set Package Transfer file name with standard name format
  • 4648 - Now correctly excluding disabled deployment targets from licensing limits

Changes in Octopus Server 2018.6.2

  • 4383 - Specific and Excluded targets are retained when a deployment fails and it is then re-tried
  • 4415 - Improvements for when choosing a tag with a large number of tenants on the create deployment screen
  • 4590 - Trials started after 30 March 2018 will not fall back to the free Community Edition https://octopus.com/blog/removing-free-tier
  • 4606 - Fix for unknown environment/certificate issue on Service Fabric targets
  • 4627 - Fixing some daily UX frustrations
  • 4631 - The markdown renderer now ignores _ in the middle of words for formatting purposes
  • 4639 - Fixes an issue preventing auto machine cleaning from adding events for machine deletion

Changes in Octopus Server 2018.6.1

  • 4518 - Improved the rendering performance of the dashboard and project overview when there are a large number of cells to display
  • 4608 - ApiKeys API paging links corrected to stop error in Octopus.Clients and load all keys in the UI when a user has > 30 keys
  • 4610 - Server now checks whether there is enough free space before writing the configuration file
  • 4624 - Fixed a bug that prevented Team Add/Edit page from loading
  • 4626 - The “running tasks” link on the Configuration->Nodes page now filters for running tasks for that node, rather than all tasks on that node
  • 4629 - Added step number to the step edit page

Changes in Octopus Server 2018.6.0

  • 4496 - Added RegisterApplicationTypeTimeoutSec to Service Fabric deploy step
  • 4531 - Support for checkbox and drop-down control-types for prompted variables
  • 4571 - Allow migrations by the API between Octopus instances
  • 4605 - External workers have been converted to workers in the default pool and the command line options have been removed, see our documentation on how to manage them
  • 4617 - Fix a bug where confirm dialog is missing when deleting a parent step from the deployment process