Compare releases

Compare releases and check for compatibility between your existing Octopus Server and new releases.

→
Loading

Unable to load comparison data

We're sorry, we're unable to load that release comparison at this time. Please try again in a few moments.

What's new

These are the most important features you'll get by upgrading from 2018.8.12 to 2018.9.13

Octopus 2018.9

Highlights

Kubernetes

2018.9 removes the alpha feature-flag from the Kubernetes support in Octopus!

The following pieces are now fully-supported members of the Octopus family:

Offline Drop Artifacts

Offline Package Drop targets can now be configured to persist the bundle as an Octopus Artifact.

Offline Package Drop targets could previously only persist the bundle to a file-system directory, which wasn't suitable for Octopus Cloud instances. Artifacts are a perfect fit for this; the deployment bundle is persisted a zip file stored against the deployment in Octopus.

Cloud Dependency Updates

All the Cloud dependencies that ship with Octopus have had an update in 2018.9

  • Azure PowerShell modules upgraded from 5.7.0 to 6.8.1. This update fixes some known issues with the 5.7.0 release of Azure PowerShell.
  • Azure CLI upgraded from 2.0.42 to 2.0.45
  • AWS PowerShell modules upgraded from 3.3.225.1 to 3.3.343.0
  • AWS CLI upgraded from 1.16.6 to 1.16.15
  • Terraform CLI upgraded from 0.11.5 to 0.11.8
  • Terraform AzureRm plugin version 1.16.0
  • Terraform AWS plugin version 1.39.0

Release notes

These are the features and fixes you'll get by upgrading from 2018.8.12 to 2018.9.13.

Changes in Octopus Server 2018.9.13

  • 4156 - Fixed highlighting of the selected element in drop downs that allowed filtering (e.g. the Add Member to Team dialog)
  • 5116 - Fixed validation around Java package steps that could be saved without selecting a package
  • 5117 - migrator.exe now correctly exports all dependencies used by a project and any of its releases, where beforehand any dependencies removed from the project would not be exported subsequently causing the import to fail
  • 5119 - migrator.exe now correctly exports all versions of any action templates used by a project and any of its releases, where beforehand only the specific versions in use were exported causing potential errors after import
  • 5122 - Tweaked shortcut menu for package feeds to make common actions more discoverable
  • 5125 - Long project names will now wrap in the project quick search dropdown
  • 5127 - migrator.exe partial-export now supports exporting multiple projects by specifying the --project="MyProjectName argument multiple times, or by project groups using the new --projectGroup="MyProjectGroup1" argument or in any combination of the two
  • 5132 - The count of releases and deployments sent to octopus.com as telemetry has been corrected to use the DeploymentHistory table

Changes in Octopus Server 2018.9.12

  • 4411 - Fix text color of Tenant Tag tooltip so description is visible
  • 4672 - Fix an issue where enter causes the variable editor to save when adding a new variable
  • 4947 - Fix an issue where bottom action buttons for lists would be duplicated or constantly appear and disappear
  • 5060 - Changing a projects lifecycle now correctly re-renders the phases and environments
  • 5091 - Fix F# compatibility with mono version 5.16
  • 5103 - Improved summary text for subscription filters
  • 5104 - Added Octopus.Machine.Hostname to automatic variable completion list
  • 5105 - Added help text for User Profile -> Api Keys
  • 5106 - Ensure deployment target icons are shown at smaller screen resolutions
  • 5107 - The icon on disabled chips is now grayed out in the same way as the text
  • 5108 - Infrastructure page now correctly shows worker pools and workers tabs when user has permission
  • 5109 - Fixed missing variable icon overlapping the project name on the tenant variable screen
  • 5111 - Long project names no longer overlap the selected environments on the tenant variable screen
  • 5112 - Fix an issue where default ports were not provided for ssh and listening tentacles during creation
  • 5113 - Helm deployments fail with target using cloud account
  • 5114 - API key creation now creates an audit log, regardless of who you create the key for
  • 5120 - New NGINX feature available when deploying a package to SSH Deployment targets

Changes in Octopus Server 2018.9.11

  • 5095 - Resolved issue where project versioning-strategy was being cleared when upgrading from Octopus 2018.8.x to 2018.9
  • 5097 - Fix a bug where VariableSet cannot be retrieved through Deployment.ManifestVariableSetId when there is variable scoped to channel
  • 5098 - Fix for Service Fabric targets API failing to retrieve store location/name override
  • 5100 - migrator.exe now correctly exports library variable sets used by a project and any of its releases, where beforehand any library variable sets removed from the project would not be exported subsequently causing the import to fail
  • 5101 - Migrator now correctly remaps tenant tag references when the tag-set exists on the destination

Changes in Octopus Server 2018.9.10

  • 4817 - Subscription emails now display events in ascending order by the time the event occurred
  • 4846 - Reduced queue time in some instances for tasks resuming from manual intervention
  • 4941 - Guided failure for required steps no longer presents the option to skip the step or exclude a machine from the step
  • 5077 - Exposed image pull policy settings for K8S containers
  • 5078 - Standalone ingress rules now accept variable host names
  • 5080 - Fix a bug where wrong permission is used when try changing lifecycle for a project
  • 5082 - migrator.exe now correctly handles importing accounts restricted to environments or tenants where some of those environments or tenants do not exist in the target
  • 5084 - migrator.exe now correctly handles importing project triggers which filter events for certain environments where some of those environments do not exist in the target
  • 5085 - migrator.exe now correctly handles importing deployment targets belonging to certain environments or tenants where some of those environments or tenants do not exist in the target
  • 5086 - migrator.exe now correctly handles importing account variables, where before the account variable was not remapped correctly from source to target
  • 5090 - Fixed issue with subscription webhooks using wrong http header type
  • 5093 - Octopus Cloud licenses are excluded from compliance pre-condition checks when upgrading the database or applying a new license
  • 5094 - If a database upgrade script is running for a long time without showing any progress messages, we now log a "still working" message every minute until the script completes

Changes in Octopus Server 2018.9.9

  • 5021 - Kubernetes target certificates now reported in certificate usage
  • 5052 - User accounts for Octopus Support Staff can now be added to an Octopus Server regardless of license limits
  • 5054 - Resolved issue introduced in 2018.9.0 where updating step template usages was causing exception when viewing project
  • 5079 - Resolved logging format exception when executing database upgrade script
  • 5080 - Fix a bug where wrong permission is used when try changing lifecycle for a project
  • 5087 - migrator.exe now correctly handles importing variable values scoped to tenants via tenant tags

Changes in Octopus Server 2018.9.8

  • 4920 - Fixed issue with packages not being listed when using TeamCity 2018.1.x legacy NuGet feeds
  • 5066 - Fixed an issue with the S3 step where invalid bucket keys were being used when using multiple file selections
  • 5072 - migrator.exe now gracefully handles the importing tenant + project + environment connections when the project or environment does not exist in the target
  • 5081 - migrator.exe now correctly handles importing subscriptions which are filtered by tenant tags

Changes in Octopus Server 2018.9.7

  • 5020 - fixed some rare cases of certificate read failures after upgrading to 2018.8.7
  • 5032 - Fix a bug where IE 11 does not render artifacts URL correctly
  • 5056 - UI legacy toggle on Azure steps to access older template functionality
  • 5058 - Fixed issue with Deploy Release step not always failing when the release fails
  • 5061 - Enable full screen mode for the variable editor dialog
  • 5065 - migrator.exe now correctly handles the default worker pool selected by certain deployment targets, where the selection would have been dropped during the import process
  • 5068 - Folders with Junctions can now be deleted again
  • 5069 - migrator.exe now correctly handles the worker pool selected for actions in a deployment process, where the selection would have been dropped during the import process
  • 5070 - kubectl config file is now displayed in the verbose logs
  • 5071 - The package cache and working directory can now be configured
  • 5076 - Fixed up integration with http://Quay.io|Quay.io docker repo

Changes in Octopus Server 2018.9.6

  • 5013 - Significant decrease in the amount of data persisted with deployments, especially when using a large number of certificates
  • 5059 - Increased the database connection timeout and transaction commit/rollback timeout for database upgrades to 3 minutes, just like it was before 2018.9.0
  • 5063 - Fixed validation for kubernetes volumes that referenced external configmaps or secrets

Changes in Octopus Server 2018.9.5

  • 5024 - Database upgrade scripts now consistently roll back to the last known good state regardless of which specific kind of upgrade script fails
  • 5038 - Database upgrade scripts now use an infinite SQL command timeout consistently - we really want the upgrade to complete even if a particular command takes a longer time than expected
  • 5055 - K8S standalone Secret and ConfigMap steps deploy as expected now

Changes in Octopus Server 2018.9.4

  • 4849 - Deployments are now removed from the dashboard again when they or their release is deleted
  • 4957 - The dashboard now correctly shows the updated version number of a release again when it is changed
  • 5054 - Resolved issue introduced in 2018.9.0 where updating step template usages was causing exception when viewing project

Changes in Octopus Server 2018.9.3

  • 4969 - Dashboard can be cached longer than 2 seconds
  • 5037 - Step template usages are now sorted alphabetically
  • 5043 - Show more informative summary text for an Active Directory identity when the specified account has no email address set
  • 5048 - Added pod and node affinity settings to the k8s container deployment step
  • 5050 - Only show the channel chip on the task summary page if the project has more than one channel
  • 5051 - Migrator now remaps Deploy Release step projects

Changes in Octopus Server 2018.9.2

  • 5029 - UI improve the lifecycles list for long lifecycles
  • 5039 - Updated the UI design and user-experience when adding new deployment targets/workers
  • 5041 - The task summary page now shows the channel chip
  • 5044 - Resolved issue with multiple channel rules introduced in 2018.9.0
  • 5046 - Instead of limiting workers and worker pools by licensing, we now only limit workers themselves, allowing you to create as many worker pools as you want
  • 5047 - Sensitive output variables are now masked in the task logs of child steps (CVE-2018-18900)

Changes in Octopus Server 2018.9.1

  • 5023 - User accounts from certain email domains can be excluded from billing at the discretion of the service provider
  • 5025 - Improvements to concurrency protection on variable sets
  • 5026 - Call to api/projects?name=[test] fails because of the special chars
  • 5027 - Sensitive Template Project variables on a Tenant will now show "value required" warning when they are empty
  • 5028 - Now preventing the SQL Database connection string from containing both Integrated Security and SQL Authentication with User ID or Password to prevent confusion
  • 5035 - Bundled Tentacle 3.23.2 which fixes a bug in the Tentacle Manager that was preventing showing instances
  • 5036 - 2018.9.0 introduced an issue where upgrading was converting offline-package-drop targets to use artifact mode
  • 5042 - 2018.8.0 introduced an RCE flaw in YAML parsing (CVE-2018-18850) which is now rectified

Changes in Octopus Server 2018.9.0

  • 4302 - The built-in worker command-line interface handles machine\user and domain\user formats more gracefully
  • 4574 - Updated the Azure PS bundle to 6.8.1 and the Azure CLI to 2.0.45
  • 4774 - Offline-Drop targets can now store the bundle as an Octopus Artifact
  • 4871 - The interruption and artifact APIs now have an ETag, lessening the load on the database
  • 4953 - In 2018.8 it was possible to corrupt auto-release-creation and channel rules by renaming package references on script steps
  • 4954 - Allow script step package references to be used for project versioning
  • 4970 - Updated the AWS PS bundle to 3.3.343.0 and the AWS CLI to 1.16.15
  • 4971 - Updated Terraform to 0.11.8, the AzureRM plugin to 1.16.0, and the AWS plugin to 1.39.0
  • 4989 - Fix for error reporting missing variable set snapshot NullReferenceException during deployments and variable set editing
  • 4990 - Built-In Worker settings are now displayed on the Configuration->Nodes->Server Settings page
  • 4995 - Exposed annotations for the pod resources created by the Kubernetes deployment resource
  • 4997 - The path command-line interface now validates paths and tries to create the path if it does not exist
  • 5017 - The Octopus.Server.exe database --upgrade --skipLicenseCheck command actually skips the license check properly now
  • 5018 - Fixed a bug with auto login when only the Active Directory provider was enabled
  • 5019 - K8S service annotations now exposed like Ingress and Deployment annotations