Compare releases

Compare releases and check for compatibility between your existing Octopus Server and new releases.

→
Loading

Unable to load comparison data

We're sorry, we're unable to load that release comparison at this time. Please try again in a few moments.

Release notes

These are the features and fixes you'll get by upgrading from 2018.3.13 to 2018.4.1.

Changes in Octopus Server 2018.4.1

  • 4178 - The built-in repository can now delete unused packages that are dynamically referenced. See the details of this issue for instructions on how to enable this feature
  • 4393 - Offline drop now only includes each package once per release
  • 4456 - Individual variable files can now be listed in the Terraform step, and the apply and init terraform actions can have additional arguments passed to them
  • 4471 - Added tenant selector for running ad-hoc scripts per tenant
  • 4477 - The permission required to delete users has been relaxed from AdministerSystem to UserEdit, with the caveat that you cannot delete yourself, and only System Administrators can delete other System Administrators
  • 4479 - Fixed SQL error when using taskState in deployments API
  • 4481 - Octopus.Action.Terraform.CustomTerraformExecutable can be set to the location of a customer terraform executable
  • 4483 - Task details page doesn't crash anymore when the log contains PowerShell code that invokes a static method
  • 4485 - Improved performance in reading the stream from SSH targets
  • 4488 - The Server Extensibility API has changed and custom extensions will need to be updated
  • 4490 - Convert OfflineDrop Write-Host to Write-Output in bootstrapper
  • 4491 - Resolved a step execution performance issue when there are lots of variables that was introduced in 2018.3.8
  • 4493 - Terraform updated to 0.11.7

Changes in Octopus Server 2018.4.0

  • 4335 - Breaking change Automatic release creation now selects packages appropriate for the channel the release is created in
  • 3633 - Added a new project trigger for recurring scheduled deployments
  • 4365 - Deployment Steps can be marked as required, meaning they cannot be skipped when customizing a deployment
  • 4422 - Fixed a problem where Variable Sets were deleted even when they were used by existing releases
  • 4433 - Release version search in Deploy a Release now displays Load More
  • 4448 - Fix for error when filtering Tenants and user does not have view permissions for some Environments
  • 4463 - Fix for show and hide empty groups on Project dashboard
  • 4473 - Fixes for “Deploy To” button popover on mobile
  • 4482 - Added the new AWS S3 upload step for uploading files to an S3 bucket with all the bells and whistles