Cowboy in the desert.

Octopus 3.1 will require .NET 4.5

Paul Stovell

.NET logo

For the longest time, Octopus and Tentacle have been built against .NET 4.0. We'd wanted to move to 4.5 since it first came out, but there was a problem:

  1. 4.5 is an in-place upgrade over 4.0
  2. If we built Octopus (or especially Tentacle) for 4.5, 4.5 would have to be installed on your servers
  3. There are a few minor breaking changes in 4.5 that could break applications that weren't tested with 4.5 installed
  4. While these don't affect Octopus/Tentacle, they could affect your other applications
  5. Bonus: .NET 4.5 isn't supported on Windows Server 2003

Over time these arguments are holding less and less weight. .NET 4.5 was released in August 2012, so most applications that encountered these issues should have been fixed by now. Windows Server 2003 hit its end-of-life earlier this month, so there's no reason we should continue to support it either.

There's also a very compelling reason for us to switch to .NET 4.5: .NET 4.0 is limited to TLS 1.0. Moving to .NET 4.5 allows us to use TLS 1.2 for all future Octopus/Tentacle communication. It will also allow us to use newer 4.5-only libraries, like the latest Azure libraries.

For these reasons, Octopus 3.1 (and Tentacle 3.1) will require .NET 4.5. You can continue to use previous versions of Octopus if you're unable to upgrade to .NET 4.5.